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Notes 
(1)  Reproduction of any part of this documentation by any means is prohibited. 
(2)  The contents of this documentation are subject to change without notice. 
(3)  Comments and notification of any mistakes in this documentation are gratefully 

accepted. 
(4)  This software cannot be used with other equipment that the specified. 
(5)  EPSON will not be responsible for any consequences resulting from the use of any 

information in this documentation. 
 
Trademarks 
Microsoft®, Windows®, Windows Server® and Windows Vista® are trademarks or 
registered trademarks of Microsoft Corporation in the United States and/or other countries. 
IBM® and PC/AT® are trademarks or registered trademarks of International Business 
Machines Corporation in the United States, other countries, or both. Epson® and 
ESC/POS® are registered trademarks of Seiko Epson Corporation. Other product and 
company names used herein are for identification purposes only and may be trademarks 
or registered trademarks of their respective companies. Epson disclaims any and all rights 
in those marks. 
The Bluetooth® word mark and logos are registered trademarks owned by Bluetooth SIG, 
Inc. and any use of such marks by Seiko Epson is under license. Other trademarks and 
trade names are those of their respective owners. 
 

 
Copyright (c) 2005-2022 Seiko Epson Corporation 
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Chapter 1 Introduction 

1.1  Starting SetupPOS 
Run SetupPOS from the following program group. 

 

Figure 1 Program Group 
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In the case of Windows 8, start from the shortcut on the Start screen. 

 
 
In the case of Windows 8.1, start from the shortcut on the Start screen. 

 

 
SetupPOS should be run with Administrator privileges. Failure to do so may result 
in unexpected behavior and the open/save may not be successful. It is necessary 
to right click on SetupPOS and select "Run as Administrator". 
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1.2  Main Window 
A tree is shown on the left side of the main window. Refer to “2.3 Tree” for 
information about the tree. 
Tabs for switching between device setting panel displays are shown on the right 
side of the main window. Refer to “2.4 Device Setting Panel” for information about 
each tab. 

 

Figure 2 Main Window 

Tree Device setting panel 
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Chapter 2 User Interface Details 

2.1  Menu Items 
The structure of the menus is as follows. 
 
 File 
o Save   Ctrl+S (Refer to “3.9 Saving”) 
o Restore (Refer to “3.6 Restoring Settings”) 
 --------------- 
o Import... (Refer to “3.7 Importing”) 
o Export... (Refer to “3.8 Exporting”) 
 --------------- 
o Exit 

 
 Edit 
o Copy   Ctrl+C (Refer to “3.4 Copying Device Settings”) 
o Paste  Ctrl+V (Refer to “3.4 Copying Device Settings”) 
o Delete   Del (Refer to “3.3 Deleting Devices”) 
 ---------------- 
o Add   Ctrl+I (Refer to “3.1 Adding Devices”) 
o Modify  Ctrl+M (Refer to “3.2 Modifying Device Settings”) 

 
 View 
o Toolbar (Refer to “2.2 Toolbar”) 
o Status Bar (Refer to “2.5 Status Bar”) 
 ---------------- 
o Sort By Logical Device Name 
o Sort By EPSON Standard 
o Sort By Connection Type 
 ---------------- 
o Expand Tree Automatically (Refer to “3.13 Automatic Expanding”) 

Ctrl+A 
 

 Tools 
o Service Settings... (Refer to “3.11 Service Settings”) 
o Preferences... (Refer to “3.12 Preferences”) 

 
 Help 
o About SetupPOS (Refer to “3.14 About SetupPOS Dialog Box”) 
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2.2  Toolbar 
The toolbar has the following icons. 
 
o Save (Refer to “3.9 Saving”) 
 ----------------  
o Copy (Refer to “3.4 Copying Device Settings”) 
o Paste (Refer to “3.4 Copying Device Settings”) 
o Delete (Refer to “3.3 Deleting Devices”) 
 ---------------- 
o Add (Refer to “3.1 Adding Devices”) 
o Modify (Refer to “3.2 Modifying Device Settings”) 
 ---------------- 
o View (Refer to “2.3 Tree”) 

• Sort By Logical Device Name 
• Sort By EPSON Standard 
• Sort By Connection Type 

 ---------------- 
o Service Settings (Refer to “3.11 Service Settings”) 
o Preferences (Refer to “3.12 Preferences”) 
 

 

Figure 3 Small Icon Toolbar 

 

 

Figure 4 Big Icon Toolbar 
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2.3  Tree 
The tree shows a list of devices. The logical name of each device category is 
used as the unique device identifier. Therefore, it is not possible to use the same 
logical device name for multiple devices. 
The tree can be displayed in the following 3 ways. 
 
 Logical device name (alphabetic) 
Each device has a property known as its logical device name. Using these 
properties, devices are sorted alphabetically and shown in a tree format. 
 
 Device category (Epson display order) 
In the Epson display order, devices are classified by device category, and within 
each category, the logical device names are sorted alphabetically. 
The order of the device categories is as follows. 

• PosPrinter 
• LineDisplay 
• CashDrawer 
• Micr 
• CheckScanner 
• Electronic Journal 
• Device categories other than those shown above are shown 

alphabetically after the above list. 
 
 Connection type 
When devices are sorted using the port type, the tree is displayed in the following 
order. 

• Serial 
• Parallel 
• USB 
• Wired Network 
• Wireless Network 
• Bluetooth  

The tree can be customized, and all branches can be made to expand 
automatically. 
When the tree is shown by connection type, drag and drop of devices is 
supported. If you drag and drop a device to a different connection type, the 
connection property is changed to the property of the location to which it is 
dragged. 
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2.4  Device Setting Panel 
The following 3 tabs are shown on the device setting panel. The 3 tabs are shown 
with most devices. 
 Common tab (Refer to “2.4.1 Common tab”) 
 Port tab  (Refer to “2.4.2 Port tab”) 
 Device Details tab (Refer to “2.4.3 Device Details tab”) 

 
2.4.1  Common tab 

The Common tab is the default tab of the device setting panel. 
 Logical Device Name indicates the unique device key within the device 

category. If the field is empty, or if an already existing value is specified, an 
error message is displayed in the status bar. 

 The Device Category value is selected when a device is added, and this 
value determines what is displayed in the Device Details tab. Once a 
device is added, this value cannot be changed. 

 Device Name determines the value displayed in the Port tab. 
 

 

Figure 5 Common Tab 
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2.4.2  Port tab 
The property value of this tab is determined by the selected Device Name on the 
Common tab. 
The following 6 port types can be selected. 
 Serial 
 Parallel 
 USB 
 Wired Network 
 Wireless Network 
 Bluetooth 
When a port's type is changed, the port's own value is set to the default value. 

 

 

Figure 6 Port Tab - Serial Settings 
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Figure 7 Port Tab - Parallel Settings 

 

 
Figure 8 Port Tab - USB Settings (configuration method 1) 
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Figure 9 Port Tab - USB Settings (configuration method 2) 
 

 
Figure 10 Port Tab - Wired Network Settings 
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Figure 11 Port Tab - Wireless Network Settings 

 

 

Figure 12 Port Tab - Bluetooth Settings 
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2.4.2.1. USB 
The configuration method differs depending on the model. 
 
Models using configuration method 1: 

TM-H5000II, TM-H5200, TM-J7000, TM-J7100, TM-J7500, TM-J7600, 
TM-U230, TM-U675, TM-U950 

 
Models using configuration method 2: 

Models not listed in Models using configuration method 1 
 

USB Configuration Method 1 
In Port Name Type, the following can be selected. 
 
• Device Name: 

Searches for the device using the device name. Select this normally. 
Multiple models of the same type cannot be used. If multiple models of the 
same type are used in USB connections at the same time, set according to 
the following "Multiple models of the same type are used at the same 
time". 

• PortName: 
Searches for the device using USB symbolic link name. 

• Serial Number:  
Searches for the device using the serial number.  

• Automatic search:  
Searches for connected Epson device automatically and uses the first 
device found. Only one device can be used with this setup. If multiple 
models of the same type are used in USB connections at the same time, 
set according to the following "Multiple models of the same type are used 
at the same time". 

 
Precautions when registering LineDisplay and CashDrawer 

When you select "USB" in the ConnectionType selection window, the 
configuration window for "USB Configuration Method 2" will appear. Then, 
when you change "Connected Printer" in the Common selection window, the 
configuration window for "USB Specific Settings" will change. 
The settings must be changed when registering multiple logical devices of 
the same model. Bring up the "USB Specific Settings" window again to adjust 
the settings. 
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Multiple models of the same type are used at the same time 
If multiple models of the same type are used in USB connections at the same 
time, settings must be configured manually. 

 
1) Set the USB port setting [Port Name Type] to [Serial Number]. 
2) Specify the USB serial number as the port name. 
 
The USB serial number is a serial number provided exclusively for USB. 
The USB serial number can be checked with a printer self-test print. 
 
When the print results are in format a), the part shown as "ID" is the USB 
serial number (in the example below YYYYYYYYYYYYYY is the serial 
number).  
When the print results are in format b), the USB serial number is the same as 
the printer serial number. In this case, check the label attached to the printer. 
 

a) When the USB serial number is printed 
---------- 
    : 
Firmware Version X.XX ESC/POS 
 
Interface UB-UXXXX Ver.X.XX 
ID  :YYYYYYYYYYYYYY 
    : 
    : 
---------- 

 
b) When the USB serial number is not printed 

---------- 
    : 
Firmware Version X.XX ESC/POS 
 
USB Interface or other 
    : 
    : 
---------- 
* "USB Interface or other" shown above may be printed simply as "USB 
Interface." 
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Note that when setting the device using this method, changing a device with 
a different USB serial number, requires changing the SetupPOS settings. 

 
USB Configuration Method 2 

Specify the logical port to which the device will be connected. The logical port 
refers to “TMPORTxxx”. “xxx” is the port number. 

・ When "Create a new port" is selected, a new logical port is created and 
linked to the logical device. 

・ If an existing logical port is selected from the list, that port is linked to the 
logical device. 

 
When registering a device for the first time 
Select "Create a new port" to create a logical port and assign the device to it. 
 
When registering multiple logical devices of the same model 
Each time you register a device, select "Create a new port" to create a logical 
port and assign the device to it. 
 
When using Micr, CheckScanner, or ElectronicJournal in the same device 
in addition to PosPrinter 
Assign all devices to a single logical port. 
 
When connecting LineDisplay or CashDrawer to Printer 
Assign all devices to a single logical port. 
 
Use the "Save" button to finalize the logical port information. The appearance 
changes after the information has been finalized. 

Before being finalized with the "Save" button 
 "New TMPORT" 

After being finalized with the "Save" button 
 "TMPORT" 
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When registering a device with SetupPOS for the first time under the following 
conditions, a logical port might already be assigned. In such cases, reconfigure 
the logical port assignment. 

・ The device was connected before being registered 
・ Other Epson-made software is installed 
・ The software was uninstalled and reinstalled while the device was 

registered 
 

2.4.2.2. Bluetooth 
Input the COM port of the Bluetooth device under Port Name. 

Ex.: COM5, etc. 
Before registering a Bluetooth-connected device in SetupPOS, configure the 
COM port of the Bluetooth device.  

 
2.4.3  Device Details tab 

The Device Category value on the Common tab determines what is displayed in 
this tab. 
For details of the Device Details tab, refer to the “Application Development Guide” 
of the relevant device. 
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2.5  Status Bar 
The status bar displays useful information about the functions of the application. It 
also displays error messages. 

 
2.6  Add Device Dialog Box 

The Add Device dialog box is for adding devices. A maximum of 4 panels are 
displayed one at a time. To move between panels, click Next and Previous. On 
the last page, Next changes to Finish. Click Cancel to exit the dialog box without 
adding a device. 
The status bar displays error messages concerning invalid values for that panel. If 
there are invalid values, the content of the text box is shown in red, and Next and 
Finish cannot be clicked. 
The content shown on other panels changes according to the device category 
and device name on the first panel. 
 
The following screen is the first panel. 
 

 

Figure 13 Add Device Dialog Box 
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When Finish is clicked, the device is added to the tree in the main window, while 
the details are displayed in the device setting panel on the right side of the main 
window. This window cannot be edited by default. Refer to “3.2 Modifying Device 
Settings” for how to edit the settings. 
 
Note that in some cases, the communication settings can not be set.  If this 
occurs, the following error message will be displayed. 
 

 
 

In this case, quit SetupPOS, open up a Command Prompt and type "net stop 
EPSON_Port_Communication_Service".  Then reload SetupPOS and add your 
device again. 
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2.7  Service Setting Dialog Box 
Tracing, Device Statistics, and Compatibility properties can be changed on the 
Service Setting dialog box. 
 

2.7.1  Tracing Mode 
There are 3 tracing function settings. 

 
 Enable Tracing 
Enables/disables the tracing function. 
The function is disabled by default. 

 
 Tracing File 
Sets the file name for saving the tracing settings 
The setting can be changed when the tracing function is enabled. 
The location of the trace file is as follows. 

(System Drive):¥ProgramData¥EPSON¥pos¥tm¥Trace¥ 
 

 File Max Size 
Sets the maximum file size for saving the tracing function. 
The setting can be changed when the tracing function is enabled. 
When the size of the tracing file is over the specified maximum size, a backup 
file of the tracing file is created. If a backup file is created when there is a 
backup file already, the new one overwrites the old one.  

 
Changing the tracing function settings updates the tracing property for all the 
devices. 
 

2.7.2  Device Statistics 
Device Statistics is ON by default. Switching Device Statistics ON and OFF 
updates the Device Statistics property for all the devices. 
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2.7.3  Compatibility 
Set compatibility for OPOS.NET1.9. 

Not Selected: Not compatible with OPOS.NET version 1.9 
The specifications for the initialization, peripheral devices, 
and Error Event are operated in compliance with UPOS1.11. 
(UPOS Specification) 

Selected: Compatible with OPOS.NET version 1.9 
The specifications for the initialization, peripheral devices, 
and Error Event are operated in compliance with the 
specifications Pre-Version 1.11 (EPSON Specification) 

The default setting is “not selected” 
 

2.7.4  Communication Compatibility 
Set compatibility for communication. 

Not Selected: No compatibility between USB and serial. 
 Normal USB operation. 
Selected: USB and serial will be compatible. 
 Operation will be equivalent to a serial connection. 

The default setting is “not selected” 
 

 
Figure 14 Service Setting Dialog Box 



Version 1.14.25  Dec. 2022 
 
 

 

User's Reference 

SetupPOS 

20 

2.8  Preferences Dialog Box 
You can set the properties for how SetupPOS is displayed on the Preferences 
dialog box. The settings are reflected when the program is next started up. 
The following 3 setting items are available. 
 Locale 

English, Japanese and Chinese are supported. 
If the locale cannot be determined, English is used by default. 

 Icons 
You can select big or small icons for the toolbar. However, the size of the tree 
icons is fixed (refer to Figure 3 and Figure 4). 

 Show Toolbar text 
You can set whether or not to display the text for the toolbar buttons. To 
display the text, check the check box. 

 

 

Figure 15 Preferences Dialog Box 
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Chapter 3 Functions 

This chapter describes some of the functions supported by SetupPOS. 
 
3.1  Adding Devices 

With the Add Device dialog box, you can add devices with a wizard. The dialog 
box is activated as follows. 
 On the toolbar, click Add. 
 In the Edit menu, click Add. 
 Right-click the device in the tree and click Add in the context menu. 
 Shortcut key: Ctrl + I 
When an added device is saved, it is added to a file. 
Refer to “2.6 Add Device Dialog Box” for how to use the Add Device dialog box. 

 
3.2  Modifying Device Settings 

When you select a device, the properties of the device are displayed in the 
default view which cannot be edited. The properties can be edited as follows. 
 On the toolbar, click Modify. 
 In the Edit menu, click Modify. 
 Right-click the device in the tree and click Modify in the context menu. 
 Shortcut key: Ctrl + M 
If a property is changed and the value is not valid, an error message is displayed 
in the status bar. 
When finishing this mode, select another device in the tree, or perform the 
procedure above again. 
When this mode is finished, the changed values are saved in memory. To save 
these values in a file, click Save. You cannot return changed values of individual 
devices to their original values. However, using the restore function, you can 
return the status of all devices to their previously saved status. Refer to “3.6 
Restoring Settings” for information about the restore function. 
SetupPOS does not support modifying the Serial port settings for a model which 
has already been registered for use with other software.  In this case, first modify 
the configuration within the software that was initially used to register it. Then 
select the same settings in SetupPOS and save. 
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3.3  Deleting Devices 
With a device selected, perform one of the following operations. There are 4 ways 
of deleting devices. 
 On the toolbar, click Delete. 
 In the Edit menu, click Delete. 
 Right-click the device in the tree and click Delete in the context menu. 
 Shortcut key: Del 
If the item selected in the tree is not a device, the delete function is disabled. 

 
3.4  Copying Device Settings 

With SetupPOS, you can copy device settings. The following ways of copying are 
available using Copy and Paste. 
 On the toolbar, click Copy and Paste. 
 In the Edit menu, click Copy and Paste. 
 Right-click the device and in the tree and click Copy and Paste in the context 

menu. 
 Shortcut key: Ctrl + C / Ctrl + V 
After selecting a device to copy, copy and then paste it. 
When you paste the device, the dialog box for changing the logical device name 
appears. Specify a new logical device name in this dialog box. Suggested names 
for the device are displayed. You can simply set a name by selecting one (you 
can also change it). If you do not select one of the suggested names and set a 
different name, it is checked to ensure that it is a valid and unique logical device 
name. 
 
If you paste the device when devices in the tree are sorted by connection type, 
the item is copied to the communication port selected in the tree. In this case, the 
port settings may be changed. For example, if you copy a serial connection 
device and paste it to a USB connection, the device changes to a USB 
connection, and the USB specific default value maintained by SetupPOS is set. 
 
If the item selected in the tree is not a device, copying is not possible. You cannot 
paste when the application is starting up and when no device has been copied. 
Also you can only copy the settings of Epson devices. 
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3.5  Transferring Device Settings 
The transfer function uses drag and drop. This can only be used when devices in 
the tree are sorted by connection type. 
To drag a device, click it with either mouse button to select it, and holding down 
the mouse button, move the device. Releasing the mouse button transfers the 
device. 
In the following cases, the drag and drop operation is ignored. 
 The tree is not displayed in the connection type. 
 The place where the device is dropped is not inside the tree. 
 The place where the device is dropped is not a connection type that the 

device supports. 
 The item dragged is not a device. 
When the device is dropped, the port settings are changed. 

 
3.6  Restoring Settings 

Using the restore function, you can return all device settings to the status saved 
in the settings file. 
To use the restore function, select Restore from the File menu. 
 
If there are unsaved changes, the changes will be lost. In this case, a pop-up 
message appears asking if you want to continue the operation or cancel it. 

 
3.7  Importing 

In the File menu, by selecting Import, you can import files into SetupPOS. 
If some of the entries conflict, a message to that effect appears, asking if you 
want to continue the operation or cancel it. If you continue the import, the 
conflicting entries are ignored. 

 
3.8  Exporting 

In the File menu, by selecting Export, you can export the device tree, including all 
devices to the specified file. 
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3.9  Saving 
You can save settings edited with SetupPOS in a settings file. 
There are 3 ways of selecting the saving function. 
 On the toolbar, click Save. 
 In the File menu, click Save. 
 Shortcut key: Ctrl + S 
You cannot save settings if there are no changes. 
*The settings information is not registered even if "Save" button is enable in case 
of no alternation in the settings. 
 

3.10  Communication Test 
Perform a communication test on the selected device using CheckHealth. 
 Right-click the device in the tree and click CheckHealth in the context menu. 
 
The following dialog box appears when CheckHealth is run. 
 

 
* The dialog box differs depending on the device. 
 
To run CheckHealth, any changes made in SetupPOS must be saved to the 
configuration file. If you run the program without saving the changes, you will be 
prompted to save them. 
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3.11  Service Settings 
You can display the Service Setting dialog box from the Tools menu. 
Some properties used with services can be changed on the Service Setting dialog 
box. 
Refer to “2.7 Service Setting Dialog Box” for how to use the Service Setting dialog 
box. 

 
3.12  Preferences 

You can display the Preferences dialog box from the Tools menu. 
You can set some of the properties used by SetupPOS on the Preferences dialog 
box. 
Refer to “2.8 Preferences Dialog Box” for how to use the Preferences dialog box. 

 
3.13  Automatic Expanding 

With Expand Tree Automatically on the View menu, you can expand and collapse 
the tree items. 
Checking an item expands that tree. Unchecking Expand Tree Automatically 
collapses the tree. In this case, only the last device displayed is not collapsed and 
remains expanded. This allows you to check which entry is displayed. 

 
3.14  About SetupPOS Dialog Box 

You can display the About SetupPOS dialog box from the Help menu. 
This dialog box displays the version information for the files required to run 
SetupPOS. 
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